nhops
nhops
3 posts
Joined March 2015

SL900 Not Dropping Shot

Hi Folks -
I'm setting up a new SL900 which doesn't seem to like dropping shot -
The transfer bar makes a full cycle, but the shot seems to be getting stuck in the drop tube -
You can see a video here:

http://67.81.22.28:22228/dillon/

Any ideas on how to fix this? - It's a constant issue, it's happening on every shell...

--nhops

dillon
Administrator
dillon
2,891 posts
Joined July 2007

RE: SL900 Not Dropping Shot

When I open the video all I see is a static shot. Can you please recheck it?
nhops
nhops
3 posts
Joined March 2015

RE: SL900 Not Dropping Shot

It should be working now -

The shot was jamming in the drop tube - I'm using reclaimed shot, which seems to have a bit of oxidation on it - I spoke w/ a service rep yesterday who suggested I try new shot...

Hopefully that will fix the issue - I also have some graphite on order, which I'm hoping will lubricate the old shot enough that it doesn't bind up.


Does anyone have any tips/input on using reclaimed shot w/ the 900?

Thanks,

--nhops

lcb
lcb
278 posts
Joined September 2007

RE: SL900 Not Dropping Shot

Reclaimed shot comes in all levels of quality.  You may need to blow it clean one more time to remove the small rocks and dust.  Then tumble it with graphite.  A pea size amount will work per 75 pounds of shot.  Mixing 50:50 reclaim with new shot will help.  Try 75:25.  Last run the shot over a screen to get out any left over small pieces of shot, rocks and dust.

Last because reclaim leaves a lot of dust, dirt, etc in the loader make sure you clean all the parts where the reclaim comes in contact.  Clean every 1000 shells or so.

Only shoot in a barrel you do not mind a scare running down the length inside.  Yes a rock can and will someday press through the plastic wad and leave a nice line down the barrel.  Sooner or later it will happen.  So only use in a shotgun you are willing to have that line down.
nhops
nhops
3 posts
Joined March 2015

RE: SL900 Not Dropping Shot

Using new shot did the trick - now I just need to dial in the hull expansion on station 2 and the primer drop and I'll be all set.

LCB - thanks for letting me know about the risk of using recycled shot - thankfully I haven't used much in the past and my barrels look fine.