Franco79
Franco79
14 posts
Joined September 2012

Rotary Primer Disk HELP!

Dillon,

 

Here is my situation. I just started to load 223 on my 650. I noticed that the small rotary primer disk was not resetting after each pull of the handle. It seemed like it was dragging, the primer indexing arm was resetting. So I took apart the primer assembly, cleaned and lubed her back up. After about 10 or so rounds, it was dragging once again and not resetting. So apart it came again and upon further inspection of the primer disk, there were smudge on it.
Also I looked at the the part where the primer feed housing sits on, it had scratches on it. Im guessing the primer disk is a harder material and was causing these marks. So I assume its binding for some reason. Well, I put her back together and played with the tightness of the 2 screws that hold the primer feed housing to the press. What I found out was that you can not screw down the screws too tight, if I loosen them, the whole housing wobbles, but the 2 parts dont bind. I didnt have this issue when I was loading 45's using the large primer disk. Im guessing the small primer rotary disk is out of spec a few thousands or so? Or is there another issue?

Here are some pictures.

[IMG]http://i1211.photobucket.com/albums/cc439/oif2003/photobucket-6411-1359658648932.jpg[/IMG]

[IMG]http://i1211.photobucket.com/albums/cc439/oif2003/photobucket-6076-1359658648413.jpg[/IMG]

[IMG]http://i1211.photobucket.com/albums/cc439/oif2003/photobucket-6346-1359658649446.jpg[/IMG]

 

Franco79
Franco79
14 posts
Joined September 2012

RE: Rotary Primer Disk HELP!

<a href="http://s1211.beta.photobucket.com/user/oif2003/media/photobucket-6346-1359658649446.jpg.html" target="_blank"><img src="http://i1211.photobucket.com/albums/cc439/oif2003/photobucket-6346-1359658649446.jpg" border="0" alt="2013-01-31_13-54-21_334 photo photobucket-6346-1359658649446.jpg"/></a>

<a href="http://s1211.beta.photobucket.com/user/oif2003/media/photobucket-6411-1359658648932.jpg.html" target="_blank"><img src="http://i1211.photobucket.com/albums/cc439/oif2003/photobucket-6411-1359658648932.jpg" border="0" alt="2013-01-31_13-56-12_2 photo photobucket-6411-1359658648932.jpg"/></a>

coltonjdavis
coltonjdavis
5 posts
Joined January 2013

RE: Rotary Primer Disk HELP!

Its a tightness issue. Tighten the disk all the way then back it off about an 1/8th of a turn.
ben mouyard
ben mouyard
1 post
Joined January 2012

RE: Rotary Primer Disk HELP!

Hi Franco,

I was having similiar problems.  What I found was a small bur on the primer

disc (probably there from when it manufactured).  With a flat file, I simply filed

it flush with the disc. 

I agree with you though, you cannot tighten the primer assembly screws too

tight.

emptech
emptech
14 posts
Joined October 2009

RE: Rotary Primer Disk HELP!

Franco:


I'm having exactly the same problem, had my 650 for many years.  In my case, the disk stuck, took it apart and found a primer in sideways.  Cleaned it, put it back together, it still isn't behaving.   Closer examination, found a small crack in the arm.  I'm bending it back, very hard metal.  Because the metal had a crack, I wasn't getting the full stroke when the disk was to advance.  Once I bend the thing to where it's reliable, I'll tack weld the part, don't want to take the temper out of it though, after welding, got to quench it quick.  I think it is a poorly designed part.  I'm going to try to get a replacement from Dillon, but don't know how busy they are.

Jim