maswiger
maswiger
2 posts
Joined February 2017

Primer ejector inconsistent...

I have Super 1050 and reload 9mm cleaned range brass from Everglades. I am finding that the resizer/deprimer die on station one doesn't always completely remove the old primers. This causes the swage station to compress the old primer into the case's primer pocket.

I replaced the deprimer pin inside this die with a new one, it helped some. However I still have pile-ups when this happens (one out of maybe 50 cycles). It's frustrating and leads to inconsistent loads.

I measured old the deprimer pin at .065", then the new one at .004 more. Is this correct? I don't see any adjustments to lower the deprimer pin because the die is set at bottom of travel to level of shell holder.

Any suggestions?
maswiger
maswiger
2 posts
Joined February 2017

RE: Primer ejector inconsistent...

Sorry, .650".
Phadrian
Phadrian
2 posts
Joined January 2012

RE: Primer ejector inconsistent...

One of two things,
1. You have a broken e-clip at the top of your decapping stem.
2. The spring inside your decapping stem is broken or malfunctioning.

If neither of these are the problem then your something is wrong with the stem itself.

We usually have several of these decapping stems set up and ready to go. Then if for reason a decap pin gets bent, e-clip or spring breaks, we simply unscrew the broken stem and put in the replacement and then we can keep going.
roastbeeflabia
roastbeeflabia
3 posts
Joined September 2018

RE: Primer ejector inconsistent...

Wet Tumbled brass?