Blueskin
Blueskin
4 posts
Joined March 2018

pick up tube problem

I have had a 550 C for a month. Works fine. I have loaded 1000 9mm so far. At first my small caliber pick up tubes worked fine. Suddenly all four of mine started to have stuck primers in the yellow plastic ends after picking up 2 or 3 primers! They were stuck hard enough i could not push them out without fear of detonation. I was able to pry them out using my fingernail. I called Dillon and they are sending me 6 new tubes.(very generous of them)

Anyone else have this problem? Maybe i just go some bad yellow plastic adapters?
coderpitt
coderpitt
92 posts
Joined November 2012

RE: pick up tube problem

What brand primers are you using? I've loaded around 13k or so and haven't had issues with the pickup tubes. I predominately use Winchester, but lately I've been using some CCI. With the CCI, they pick up fine, I just have to use the primer follower rod when dropping them because they seem to be slightly larger or out of round compared to Winchester.... but I've done a couple thousand with them with no issue. If the pickup end is too tight you can work the sides open a little, but if you do it to much you'll end up replacing the yellow part.
Blueskin
Blueskin
4 posts
Joined March 2018

RE: pick up tube problem

Thanks for your input. I have always used Winchester Primers.
LeftyTSGC
LeftyTSGC
26 posts
Joined February 2013

RE: pick up tube problem

You may only have needed to run a swab with alcohol thru them to make sure no debris is in them. You mentioned the yellow plastic ends is where the primers got stuck, make sure you are not over doing the pickup with a lot of force, You probably did not need new tubes, but only the plastic pickup ends.